I have a mild case of analysis paralysis when it comes to naming.<p>Suppose we are wrapping some google API. These all seem reasonable:<p>googleClient
googleDriver
googleActor
googleAdapter
googleBroker<p>Actor might be more suited to a more concurrent program. But then google API is inherently asynchronous so maybe a good fit.<p>Suppose the API supports websockets or push messages and it supports methods like `.subscribeToEventA(...` it might make sense to call it<p>googleEmitter
googlePubSub
googleEventBus<p>or even<p>googleWrapper<p>The issue being they all seem reasonable and I have no rule of thumb for choosing between them. Is there a general style guide to lean on or a rule of thumb? Maybe some authoritative glossary for terms like these?