Frankly I'm a bit torn on this one as f(x=x) is indeed a common pattern and having just f(x=) reduces the need for multiline invocations but I feel like adding syntatic sugar to python at this point is just giving the snake diabetes.
Since any argument after one or more "**" must be a keyword-argument, perhaps f(pos_a, pos_b, **kwargs, kw_a, kw_b, ...) or even f(pos_a, pos_b, **, kw_a, kw_b, ...).<p>This would make the proposal's first example read:<p><pre><code> my_function(**, my_first_variable, my_second_variable, my_third_variable)
</code></pre>
More readable IMHO. They do mention f(a, b, *, x) in the proposal and present some objections, but arguably ** makes it easy to understand that these are keyword arguments.
Finally! This makes constructing dicts so much easier. I somewhat dislike the syntax though, =foo would have been better because it stands out more. I feel like syntax should be chosen with eyes and not brain, they may have all kinds of rationales for why foo= is better but it's just going to get lost more easily.
my_function(my_first_variable=, my_second_variable=, my_third_variable=)<p>The coder's laziness have gone too far. That's ridiculous.<p>Just checked, the author is a Google folk, that says a lot.